Degraded performance

Incident Report for Schoox Inc

Resolved

AWS has appeared to have resolved all connectivity issues at this time. Background tasks and commands are still being processed but they are actively being completed. We appreciate your patience in this matter.
Posted Oct 21, 2025 - 00:36 UTC

Update

Some background actions and commands may be delayed due to the ISP outage that is happening in the US.
Posted Oct 20, 2025 - 18:27 UTC

Monitoring

Amazon Web Services experienced a major global outage originating in its US-EAST-1 region, stemming from DNS resolution issues with the DynamoDB API endpoint, which cascaded to disrupt dependent services on our application. AWS engineers had mitigated the root cause, with most services recovering and operating normally, though some residual throttling and delays persisted as full resolution efforts continued.

We are currently monitoring the situation from our end to ensure smooth functionality on our application and intervene if necessary in a effort to resolve anything that is inside of our sphere of influence.
Posted Oct 20, 2025 - 10:56 UTC
This incident affected: Web App, API, and SAML SSO.